$re = '/^\d+[a-z\d]$/m';
$str = '29c
29
a
2
2425315651252fsaw
24241jl.421c
29c is fine
29 is fine
2425315651252fsaw fails
24241jl.421c fails';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);