// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+[a-z\d]$").unwrap();
let string = "29c
29
a
2
2425315651252fsaw
24241jl.421c
29c is fine
29 is fine
2425315651252fsaw fails
24241jl.421c fails";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}