import re
regex = re.compile(r"^\d+[a-z\d]$", flags=re.MULTILINE)
test_str = ("29c\n"
"29\n"
"a\n"
"2\n"
"2425315651252fsaw\n"
"24241jl.421c\n\n"
"29c is fine\n"
"29 is fine\n"
"2425315651252fsaw fails\n"
"24241jl.421c fails")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")