using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z][0-9][A-Z0-9](?:\.[A-Z0-9]{1,4})?$";
string input = @"A12.0
A12.A9
A12.A9A9
A12.ZZZZ
A12.9999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}