// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z][0-9][A-Z0-9](?:\.[A-Z0-9]{1,4})?$").unwrap();
let string = "A12.0
A12.A9
A12.A9A9
A12.ZZZZ
A12.9999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}