const regex = new RegExp('^[A-Z][0-9][A-Z0-9](?:\\.[A-Z0-9]{1,4})?$', 'gm')
const str = `A12.0
A12.A9
A12.A9A9
A12.ZZZZ
A12.9999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}