$re = '/^[A-Z][0-9][A-Z0-9](?:\.[A-Z0-9]{1,4})?$/m';
$str = 'A12.0
A12.A9
A12.A9A9
A12.ZZZZ
A12.9999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);