import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z][0-9][A-Z0-9](?:\\.[A-Z0-9]{1,4})?$";
final String string = "A12.0\n"
+ "A12.A9\n"
+ "A12.A9A9\n"
+ "A12.ZZZZ\n"
+ "A12.9999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}