use strict;
my $str = 'A12.0
A12.A9
A12.A9A9
A12.ZZZZ
A12.9999';
my $regex = qr/^[A-Z][0-9][A-Z0-9](?:\.[A-Z0-9]{1,4})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}