#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){([^{}]+)}"
Local $sString = "Hello {name}, how are?" & @CRLF & _
"Hello {name}, how are you? My name is {managers.0.name}" & @CRLF & _
"Hello {0}, how are you? My name is {1}" & @CRLF & _
"Hello {{{{1}}}}" & @CRLF & _
"Hello {managers.0.name} Hello {{{{managers.1.name}}}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")