const regex = /{([^{}]+)}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{([^{}]+)}', 'gm')
const str = `Hello {name}, how are?
Hello {name}, how are you? My name is {managers.0.name}
Hello {0}, how are you? My name is {1}
Hello {{{{1}}}}
Hello {managers.0.name} Hello {{{{managers.1.name}}}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}