import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{([^\\{\\}]+)\\}";
final String string = "Hello {name}, how are?\n"
+ "Hello {name}, how are you? My name is {managers.0.name}\n"
+ "Hello {0}, how are you? My name is {1}\n"
+ "Hello {{{{1}}}}\n"
+ "Hello {managers.0.name} Hello {{{{managers.1.name}}}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}