using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{([^{}]+)}";
string input = @"Hello {name}, how are?
Hello {name}, how are you? My name is {managers.0.name}
Hello {0}, how are you? My name is {1}
Hello {{{{1}}}}
Hello {managers.0.name} Hello {{{{managers.1.name}}}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}