$re = '/{([^{}]+)}/m';
$str = 'Hello {name}, how are?
Hello {name}, how are you? My name is {managers.0.name}
Hello {0}, how are you? My name is {1}
Hello {{{{1}}}}
Hello {managers.0.name} Hello {{{{managers.1.name}}}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);