// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m){([^{}]+)}").unwrap();
let string = "Hello {name}, how are?
Hello {name}, how are you? My name is {managers.0.name}
Hello {0}, how are you? My name is {1}
Hello {{{{1}}}}
Hello {managers.0.name} Hello {{{{managers.1.name}}}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}