#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^|\s)(?:\w?'?)(@(\S+))"
Local $sString = "1. take this -> @Mark" & @CRLF & _
"2. take this -> @mark_2" & @CRLF & _
"3. take this -> @中国" & @CRLF & _
"4. take this -> l'@antro" & @CRLF & _
"5. don't take this -> 中国@中国.zh" & @CRLF & _
"6. don't take this -> 中国@google.zh" & @CRLF & _
"7. don't take this -> info@google.com" & @CRLF & _
"8. don't take this -> 99@test.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")