import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|\\s)(?:\\w?'?)(@(\\S+))";
final String string = "1. take this -> @Mark\n"
+ "2. take this -> @mark_2\n"
+ "3. take this -> @中国\n"
+ "4. take this -> l'@antro\n"
+ "5. don't take this -> 中国@中国.zh\n"
+ "6. don't take this -> 中国@google.zh\n"
+ "7. don't take this -> info@google.com\n"
+ "8. don't take this -> 99@test.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}