const regex = /(?<=^|\s)(?:\w?'?)(@(\S+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\s)(?:\\w?\'?)(@(\\S+))', 'gm')
const str = `1. take this -> @Mark
2. take this -> @mark_2
3. take this -> @中国
4. take this -> l'@antro
5. don't take this -> 中国@中国.zh
6. don't take this -> 中国@google.zh
7. don't take this -> info@google.com
8. don't take this -> 99@test.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}