import Foundation
let pattern = #"(?<=^|\s)(?:\w?'?)(@(\S+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. take this -> @Mark
2. take this -> @mark_2
3. take this -> @中国
4. take this -> l'@antro
5. don't take this -> 中国@中国.zh
6. don't take this -> 中国@google.zh
7. don't take this -> info@google.com
8. don't take this -> 99@test.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)