use strict;
my $str = '1. take this -> @Mark
2. take this -> @mark_2
3. take this -> @中国
4. take this -> l\'@antro
5. don\'t take this -> 中国@中国.zh
6. don\'t take this -> 中国@google.zh
7. don\'t take this -> info@google.com
8. don\'t take this -> 99@test.com';
my $regex = qr/(?<=^|\s)(?:\w?'?)(@(\S+))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}