# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b( VON| VAN| DE)+\s/$1-/gim;t' <<< "HENRIETTA VON DER GRAAF
CAROLINE VAN OOSTEN DE WINKEL
MARC DE VRIES VAN JONG
ANNEKA VANHOVEN BAKKER
JOHN SMITH"