// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)\b( VON| VAN| DE)+\s").unwrap();
let string = "HENRIETTA VON DER GRAAF
CAROLINE VAN OOSTEN DE WINKEL
MARC DE VRIES VAN JONG
ANNEKA VANHOVEN BAKKER
JOHN SMITH";
let substitution = "$1-";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}