#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)\b( VON| VAN| DE)+\s"
Local $sString = "HENRIETTA VON DER GRAAF" & @CRLF & _
"CAROLINE VAN OOSTEN DE WINKEL" & @CRLF & _
"MARC DE VRIES VAN JONG" & @CRLF & _
"ANNEKA VANHOVEN BAKKER" & @CRLF & _
"JOHN SMITH"
Local $sSubst = "$1-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)