use strict;
my $str = 'HENRIETTA VON DER GRAAF
CAROLINE VAN OOSTEN DE WINKEL
MARC DE VRIES VAN JONG
ANNEKA VANHOVEN BAKKER
JOHN SMITH';
my $regex = qr/\b( VON| VAN| DE)+\s/imp;
my $subst = '$1-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";