package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\b( VON| VAN| DE)+\s`)
var str = `HENRIETTA VON DER GRAAF
CAROLINE VAN OOSTEN DE WINKEL
MARC DE VRIES VAN JONG
ANNEKA VANHOVEN BAKKER
JOHN SMITH`
var substitution = "$1-"
fmt.Println(re.ReplaceAllString(str, substitution))
}