const regex = /\b( VON| VAN| DE)+\s/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b( VON| VAN| DE)+\\s', 'gim')
const str = `HENRIETTA VON DER GRAAF
CAROLINE VAN OOSTEN DE WINKEL
MARC DE VRIES VAN JONG
ANNEKA VANHOVEN BAKKER
JOHN SMITH`;
const subst = `$1-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);