#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(‾+|(‾*\\)?(_*\/‾*\\)*_*(\/‾*)?)$"
Local $sString = "__/‾‾\/\_/‾" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"_" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"\" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"/" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"‾" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"___" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"\/" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"/\/" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"/\/\" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"‾‾‾" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"\\" & @CRLF & _
"0" & @CRLF & _
"" & @CRLF & _
"‾‾" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"_‾" & @CRLF & _
"0" & @CRLF & _
"" & @CRLF & _
"‾_" & @CRLF & _
"0" & @CRLF & _
"" & @CRLF & _
"\_____/" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"\/\\/\\___" & @CRLF & _
"0" & @CRLF & _
"" & @CRLF & _
"\/\__/‾‾\" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"______/\_____" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"‾‾‾‾‾‾\\_____" & @CRLF & _
"0" & @CRLF & _
"" & @CRLF & _
"‾‾‾‾‾‾\______" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"_____/‾‾‾‾‾" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"\___/‾‾‾\___/‾‾‾" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"\_/_\_" & @CRLF & _
"0" & @CRLF & _
"" & @CRLF & _
"\_/\_" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"/\/\/\/\/\/\/\/\/\/\/\/" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"____________________" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾/" & @CRLF & _
"0" & @CRLF & _
"" & @CRLF & _
"‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾\" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"/\‾/\‾___/|\_|\/__\/\‾‾" & @CRLF & _
"0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")