// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(‾+|(‾*\\)?(_*\/‾*\\)*_*(\/‾*)?)$").unwrap();
let string = "__/‾‾\\/\\_/‾
1
_
1
\\
1
/
1
‾
1
___
1
\\/
1
/\\/
1
/\\/\\
1
‾‾‾
1
\\\\
0
‾‾
1
_‾
0
‾_
0
\\_____/
1
\\/\\\\/\\\\___
0
\\/\\__/‾‾\\
1
______/\\_____
1
‾‾‾‾‾‾\\\\_____
0
‾‾‾‾‾‾\\______
1
_____/‾‾‾‾‾
1
\\___/‾‾‾\\___/‾‾‾
1
\\_/_\\_
0
\\_/\\_
1
/\\/\\/\\/\\/\\/\\/\\/\\/\\/\\/\\/
1
____________________
1
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾
1
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾/
0
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾\\
1
/\\‾/\\‾___/|\\_|\\/__\\/\\‾‾
0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}