const regex = /^(‾+|(‾*\\)?(_*\/‾*\\)*_*(\/‾*)?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(‾+|(‾*\\\\)?(_*\\\/‾*\\\\)*_*(\\\/‾*)?)$', 'gm')
const str = `__/‾‾\\/\\_/‾
1
_
1
\\
1
/
1
‾
1
___
1
\\/
1
/\\/
1
/\\/\\
1
‾‾‾
1
\\\\
0
‾‾
1
_‾
0
‾_
0
\\_____/
1
\\/\\\\/\\\\___
0
\\/\\__/‾‾\\
1
______/\\_____
1
‾‾‾‾‾‾\\\\_____
0
‾‾‾‾‾‾\\______
1
_____/‾‾‾‾‾
1
\\___/‾‾‾\\___/‾‾‾
1
\\_/_\\_
0
\\_/\\_
1
/\\/\\/\\/\\/\\/\\/\\/\\/\\/\\/\\/
1
____________________
1
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾
1
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾/
0
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾\\
1
/\\‾/\\‾___/|\\_|\\/__\\/\\‾‾
0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}