use strict;
my $str = '__/‾‾\\/\\_/‾
1
_
1
\\
1
/
1
‾
1
___
1
\\/
1
/\\/
1
/\\/\\
1
‾‾‾
1
\\\\
0
‾‾
1
_‾
0
‾_
0
\\_____/
1
\\/\\\\/\\\\___
0
\\/\\__/‾‾\\
1
______/\\_____
1
‾‾‾‾‾‾\\\\_____
0
‾‾‾‾‾‾\\______
1
_____/‾‾‾‾‾
1
\\___/‾‾‾\\___/‾‾‾
1
\\_/_\\_
0
\\_/\\_
1
/\\/\\/\\/\\/\\/\\/\\/\\/\\/\\/\\/
1
____________________
1
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾
1
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾/
0
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾\\
1
/\\‾/\\‾___/|\\_|\\/__\\/\\‾‾
0';
my $regex = qr/^(‾+|(‾*\\)?(_*\/‾*\\)*_*(\/‾*)?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}