re = /^(‾+|(‾*\\)?(_*\/‾*\\)*_*(\/‾*)?)$/m
str = '__/‾‾\\/\\_/‾
1
_
1
\\
1
/
1
‾
1
___
1
\\/
1
/\\/
1
/\\/\\
1
‾‾‾
1
\\\\
0
‾‾
1
_‾
0
‾_
0
\\_____/
1
\\/\\\\/\\\\___
0
\\/\\__/‾‾\\
1
______/\\_____
1
‾‾‾‾‾‾\\\\_____
0
‾‾‾‾‾‾\\______
1
_____/‾‾‾‾‾
1
\\___/‾‾‾\\___/‾‾‾
1
\\_/_\\_
0
\\_/\\_
1
/\\/\\/\\/\\/\\/\\/\\/\\/\\/\\/\\/
1
____________________
1
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾
1
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾/
0
‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾\\
1
/\\‾/\\‾___/|\\_|\\/__\\/\\‾‾
0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end