import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(‾+|(‾*\\\\)?(_*\\/‾*\\\\)*_*(\\/‾*)?)$";
final String string = "__/‾‾\\/\\_/‾\n"
+ "1\n\n"
+ "_\n"
+ "1\n\n"
+ "\\\n"
+ "1\n\n"
+ "/\n"
+ "1\n\n"
+ "‾\n"
+ "1\n\n"
+ "___\n"
+ "1\n\n"
+ "\\/\n"
+ "1\n\n"
+ "/\\/\n"
+ "1\n\n"
+ "/\\/\\\n"
+ "1\n\n"
+ "‾‾‾\n"
+ "1\n\n"
+ "\\\\\n"
+ "0\n\n"
+ "‾‾\n"
+ "1\n\n"
+ "_‾\n"
+ "0\n\n"
+ "‾_\n"
+ "0\n\n"
+ "\\_____/\n"
+ "1\n\n"
+ "\\/\\\\/\\\\___\n"
+ "0\n\n"
+ "\\/\\__/‾‾\\\n"
+ "1\n\n"
+ "______/\\_____\n"
+ "1\n\n"
+ "‾‾‾‾‾‾\\\\_____\n"
+ "0\n\n"
+ "‾‾‾‾‾‾\\______\n"
+ "1\n\n"
+ "_____/‾‾‾‾‾\n"
+ "1\n\n"
+ "\\___/‾‾‾\\___/‾‾‾\n"
+ "1\n\n"
+ "\\_/_\\_\n"
+ "0\n\n"
+ "\\_/\\_\n"
+ "1\n\n"
+ "/\\/\\/\\/\\/\\/\\/\\/\\/\\/\\/\\/\n"
+ "1\n\n"
+ "____________________\n"
+ "1\n\n"
+ "‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾\n"
+ "1\n\n"
+ "‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾/\n"
+ "0\n\n"
+ "‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾\\\n"
+ "1\n\n"
+ "/\\‾/\\‾___/|\\_|\\/__\\/\\‾‾\n"
+ "0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}