import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<wp:postmeta>[\\s\\S]*?</wp:postmeta>";
final String string = "<wp:postmeta><wp:meta_key>_edit_last</wp:meta_key><wp:meta_value><![CDATA[2]]></wp:meta_value></wp:postmeta>\n\n"
+ "<wp:postmeta><wp:meta_key>seo_follow</wp:meta_key><wp:meta_value><![CDATA[false]]></wp:meta_value></wp:postmeta>\n\n"
+ "<wp:postmeta>\n"
+ " <wp:meta_key>seo_noindex</wp:meta_key>\n"
+ " <wp:meta_value><![CDATA[false]]></wp:meta_value>\n"
+ " </wp:postmeta>\n"
+ "<wp:postmeta>\n"
+ "<wp:meta_key>_yoast_wpseo_focuskw</wp:meta_key>\n"
+ " <wp:meta_value><![CDATA[services de proximité, transports de marchandises]]></wp:meta_value>\n"
+ "</wp:postmeta>\n"
+ "<wp:postmeta>\n"
+ " <wp:meta_key>_yoast_wpseo_title</wp:meta_key>\n"
+ " <wp:meta_value><![CDATA[]]></wp:meta_value>\n"
+ "</wp:postmeta>\n"
+ "<wp:postmeta>\n"
+ " <wp:meta_key>_yoast_wpseo_metadesc</wp:meta_key>\n"
+ " <wp:meta_value><![CDATA[]]></wp:meta_value>\n"
+ "</wp:postmeta>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}