// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<wp:postmeta>[\s\S]*?</wp:postmeta>").unwrap();
let string = "<wp:postmeta><wp:meta_key>_edit_last</wp:meta_key><wp:meta_value><![CDATA[2]]></wp:meta_value></wp:postmeta>
<wp:postmeta><wp:meta_key>seo_follow</wp:meta_key><wp:meta_value><![CDATA[false]]></wp:meta_value></wp:postmeta>
<wp:postmeta>
<wp:meta_key>seo_noindex</wp:meta_key>
<wp:meta_value><![CDATA[false]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_focuskw</wp:meta_key>
<wp:meta_value><![CDATA[services de proximité, transports de marchandises]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_title</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_metadesc</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}