$re = '/<wp:postmeta>[\s\S]*?</wp:postmeta>/';
$str = '<wp:postmeta><wp:meta_key>_edit_last</wp:meta_key><wp:meta_value><![CDATA[2]]></wp:meta_value></wp:postmeta>
<wp:postmeta><wp:meta_key>seo_follow</wp:meta_key><wp:meta_value><![CDATA[false]]></wp:meta_value></wp:postmeta>
<wp:postmeta>
<wp:meta_key>seo_noindex</wp:meta_key>
<wp:meta_value><![CDATA[false]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_focuskw</wp:meta_key>
<wp:meta_value><![CDATA[services de proximité, transports de marchandises]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_title</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_metadesc</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);