use strict;
my $str = '<wp:postmeta><wp:meta_key>_edit_last</wp:meta_key><wp:meta_value><![CDATA[2]]></wp:meta_value></wp:postmeta>
<wp:postmeta><wp:meta_key>seo_follow</wp:meta_key><wp:meta_value><![CDATA[false]]></wp:meta_value></wp:postmeta>
<wp:postmeta>
<wp:meta_key>seo_noindex</wp:meta_key>
<wp:meta_value><![CDATA[false]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_focuskw</wp:meta_key>
<wp:meta_value><![CDATA[services de proximité, transports de marchandises]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_title</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_metadesc</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>';
my $regex = qr/<wp:postmeta>[\s\S]*?</wp:postmeta>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}