# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<wp:postmeta>[\s\S]*?</wp:postmeta>"
test_str = ("<wp:postmeta><wp:meta_key>_edit_last</wp:meta_key><wp:meta_value><![CDATA[2]]></wp:meta_value></wp:postmeta>\n\n"
"<wp:postmeta><wp:meta_key>seo_follow</wp:meta_key><wp:meta_value><![CDATA[false]]></wp:meta_value></wp:postmeta>\n\n"
"<wp:postmeta>\n"
" <wp:meta_key>seo_noindex</wp:meta_key>\n"
" <wp:meta_value><![CDATA[false]]></wp:meta_value>\n"
" </wp:postmeta>\n"
"<wp:postmeta>\n"
"<wp:meta_key>_yoast_wpseo_focuskw</wp:meta_key>\n"
" <wp:meta_value><![CDATA[services de proximité, transports de marchandises]]></wp:meta_value>\n"
"</wp:postmeta>\n"
"<wp:postmeta>\n"
" <wp:meta_key>_yoast_wpseo_title</wp:meta_key>\n"
" <wp:meta_value><![CDATA[]]></wp:meta_value>\n"
"</wp:postmeta>\n"
"<wp:postmeta>\n"
" <wp:meta_key>_yoast_wpseo_metadesc</wp:meta_key>\n"
" <wp:meta_value><![CDATA[]]></wp:meta_value>\n"
"</wp:postmeta>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.