using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^rainbow.*";
string input = @"rainbow blah blah window
I am a different window
I am a window that has rainbow in it but not starting with it
rainbow version 675";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}