package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^rainbow.*`)
var str = `rainbow blah blah window
I am a different window
I am a window that has rainbow in it but not starting with it
rainbow version 675`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}