$re = '/^rainbow.*/im';
$str = 'rainbow blah blah window
I am a different window
I am a window that has rainbow in it but not starting with it
rainbow version 675';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);