const regex = /^rainbow.*/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^rainbow.*', 'igm')
const str = `rainbow blah blah window
I am a different window
I am a window that has rainbow in it but not starting with it
rainbow version 675`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}