re = /^rainbow.*/im
str = 'rainbow blah blah window
I am a different window
I am a window that has rainbow in it but not starting with it
rainbow version 675'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end