// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^rainbow.*").unwrap();
let string = "rainbow blah blah window
I am a different window
I am a window that has rainbow in it but not starting with it
rainbow version 675";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}