using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SELECT\s(?:(?!FROM)[\s\S])*\sFROM";
string input = @"SELECT A
,B
,C
FROM ABC
WHERE Z = 5
AND T = 10
UNION
SELECT *
FROM GHI
WHERE i = 100
UNION
SELECT X
,Y
FROM XYZ";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}