$re = '/SELECT\s(?:(?!FROM)[\s\S])*\sFROM/is';
$str = 'SELECT A
,B
,C
FROM ABC
WHERE Z = 5
AND T = 10
UNION
SELECT *
FROM GHI
WHERE i = 100
UNION
SELECT X
,Y
FROM XYZ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);