import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SELECT\\s(?:(?!FROM)[\\s\\S])*\\sFROM";
final String string = "SELECT A\n"
+ " ,B\n"
+ " ,C\n"
+ "FROM ABC\n"
+ "WHERE Z = 5\n"
+ " AND T = 10\n\n"
+ "UNION\n\n"
+ "SELECT *\n"
+ "FROM GHI\n"
+ "WHERE i = 100\n\n"
+ "UNION\n\n"
+ "SELECT X\n"
+ " ,Y\n"
+ "FROM XYZ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}