# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"SELECT\s(?:(?!FROM)[\s\S])*\sFROM"
test_str = ("SELECT A\n"
" ,B\n"
" ,C\n"
"FROM ABC\n"
"WHERE Z = 5\n"
" AND T = 10\n\n"
"UNION\n\n"
"SELECT *\n"
"FROM GHI\n"
"WHERE i = 100\n\n"
"UNION\n\n"
"SELECT X\n"
" ,Y\n"
"FROM XYZ")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.