use strict;
my $str = 'SELECT A
,B
,C
FROM ABC
WHERE Z = 5
AND T = 10
UNION
SELECT *
FROM GHI
WHERE i = 100
UNION
SELECT X
,Y
FROM XYZ';
my $regex = qr/SELECT\s(?:(?!FROM)[\s\S])*\sFROM/isp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}