re = /SELECT\s(?:(?!FROM)[\s\S])*\sFROM/i
str = 'SELECT A
,B
,C
FROM ABC
WHERE Z = 5
AND T = 10
UNION
SELECT *
FROM GHI
WHERE i = 100
UNION
SELECT X
,Y
FROM XYZ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end