using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<[^<>]*?ww3______sinaimg______cn[^<>]*?\/\s*?>|<a[^<>]*?ww3______sinaimg______cn.+?>.+?<\/a>)";
string input = @"<img src=' ' onclick=""window.open ('http://www.viidii.info/?http://ww3______sinaimg______cn/large/bd698b0fjw1ev9gjrevg2g20a505pu0x______gif&z'); />
<a href=""ww3______sinaimg______cn"" > aaa</a>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}